Anyone else been getting MYSQL errors lately?

Forum info, updates, discussion. If you have a request for something you want to see on the forum, feel free to bring it up here.
User avatar
ST_Lawson
Site Admin
Posts: 4857
Joined: Wed Apr 16, 2014 1:15 pm
Location: Macomb, IL
Contact:

Thu Oct 06, 2016 10:44 am

I've been getting a few MYSQL errors when trying to do things like post a new topic or reply to posts. It brings up a blue error page and says stuff about the MYSQL server going away/being unavailable.

Anyone else getting errors like that, or is it just me? I might need to do some database maintenance to see if I can fix the issues, but I'm trying to nail down when exactly it's happening and who it's happening to.

Thanks for your help.
Scott Lawson - Board Admin
Western Illinois University Alum/Fan/Employee
Member of the Marching Leathernecks - 1996-2000
wiu712
Posts: 3756
Joined: Tue Apr 22, 2014 2:05 pm

Thu Oct 06, 2016 11:15 am

I got the "blue error page" a few days ago.

I thought that you were doing some maintenance work on the site and that it was temporarily unavailable. When I tried again about an hour later, things were working fine.
rocki
Posts: 815
Joined: Sat Apr 19, 2014 9:08 pm

Thu Oct 06, 2016 11:38 am

Same here. I just thought something was being updated, or that I'd entered something at the same time someone else did and it confused the system. All was fine later, so no biggie.
User avatar
ST_Lawson
Site Admin
Posts: 4857
Joined: Wed Apr 16, 2014 1:15 pm
Location: Macomb, IL
Contact:

Thu Oct 06, 2016 1:44 pm

Yea, I've noticed that if you just hit back on the browser and resubmit or reload the page, then it usually works fine the second time around. I spend a lot of time on the site, so I probably just notice it more often.

I'll see what I can do to clean that up a bit. I think it's just an issue with the mysql server getting a bit bogged down at times and I think there's some things I can do to trim up some older stuff (not posts, but like old log files/entries, search index data, etc).
Scott Lawson - Board Admin
Western Illinois University Alum/Fan/Employee
Member of the Marching Leathernecks - 1996-2000
User avatar
Tere North
Posts: 789
Joined: Wed Apr 16, 2014 10:59 pm

Thu Oct 06, 2016 9:18 pm

I get the MYSQL error periodically when I go to a new forum topic, but if I go back and try again, so far it has worked right away. More annoying than problematic, at least at this stage.
User avatar
ST_Lawson
Site Admin
Posts: 4857
Joined: Wed Apr 16, 2014 1:15 pm
Location: Macomb, IL
Contact:

Thu Oct 06, 2016 9:32 pm

Tere North wrote:I get the MYSQL error periodically when I go to a new forum topic, but if I go back and try again, so far it has worked right away. More annoying than problematic, at least at this stage.
Sure, I'm just hoping to get it fixed before it gets any worse.

I've done a bit of work with the database, so we'll see if that helps. I'll keep an eye on things and if anyone else sees it, let me know.

Thanks.
Scott Lawson - Board Admin
Western Illinois University Alum/Fan/Employee
Member of the Marching Leathernecks - 1996-2000
rocki
Posts: 815
Joined: Sat Apr 19, 2014 9:08 pm

Sat Oct 22, 2016 10:34 pm

Just got it again. Refreshed and everything was fine, but you said you wanted to know when it happened.
User avatar
ST_Lawson
Site Admin
Posts: 4857
Joined: Wed Apr 16, 2014 1:15 pm
Location: Macomb, IL
Contact:

Sat Oct 22, 2016 11:24 pm

rocki wrote:Just got it again. Refreshed and everything was fine, but you said you wanted to know when it happened.
Yup, thanks.
Scott Lawson - Board Admin
Western Illinois University Alum/Fan/Employee
Member of the Marching Leathernecks - 1996-2000
wiu712
Posts: 3756
Joined: Tue Apr 22, 2014 2:05 pm

Sun Oct 23, 2016 9:13 am

I also experienced the MYSQL error blue screen several times on Saturday.
User avatar
Tere North
Posts: 789
Joined: Wed Apr 16, 2014 10:59 pm

Thu Dec 01, 2016 10:59 am

They are showing up again when opening and when going to threads.
2016-12-01_10-57-19.jpg
2016-12-01_10-57-19.jpg (23.1 KiB) Viewed 2101 times
Post Reply